Canon SELPHY CP810 CP900 Drivers for macOS High Sierra 10.13

If you have macOS High Sierra and a Canon SELPHY CP810 or CP900, you had noticed that Canon didn’t update his drivers in a while and that you cannot install them on your new OS. Canon didn’t publish any official drivers for these printers on the latest macOS.

Well, today, you can! Thanks to a little tweak in the drivers files, it nows install perfectly on macOS High Sierra.

And here is your driver compatible with OSX 10.13 🙂

http://data.holocron.be/drivers/canon/selphy/SELPHY_CP_Series_-_macOS_High_Sierra.dmg

You might need to disable security check as said on the documentation.

Thanks redogg for the tutorial I’ve followed here: https://discussions.apple.com/message/23725252#23725252

totophe

Creative Mind, Digital Development Strategist, and Web & Marketing Technologies Consultant in Brussels, Belgium

No Comments

Leave a Comment

Leave a Reply